Thread Rating:
  • 7 Vote(s) - 4.71 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Raspberry Pi Sky Miner Setup for noobs - TESTNET READY
(10-24-2018, 10:11 PM)yonomas Wrote: can you get whitelisted with 1 raspberry pi only?
and then buy the rest?

Yep! Big Grin

Apply with one to start your whitelist que, once you get the rest of them redo your whitelist application with the new node keys and with the same email address. This will update your info on our end and you will keep your Que position.
[-] The following 1 user says Thank You to I Am You for this post:
  • yonomas
Reply
(10-26-2018, 07:25 PM)I Am You Wrote:
(10-24-2018, 10:11 PM)yonomas Wrote: can you get whitelisted with 1 raspberry pi only?
and then buy the rest?

Yep! Big Grin

Apply with one to start your whitelist que, once you get the rest of them redo your whitelist application with the new node keys and with the same email address. This will update your info on our end and you will keep your Que position.

awesome, how much time does it take to get whitelisted? It's been 2 weeks, no news
Reply
(11-03-2018, 01:22 AM)yonomas Wrote:
(10-26-2018, 07:25 PM)I Am You Wrote:
(10-24-2018, 10:11 PM)yonomas Wrote: can you get whitelisted with 1 raspberry pi only?
and then buy the rest?

Yep! Big Grin

Apply with one to start your whitelist que, once you get the rest of them redo your whitelist application with the new node keys and with the same email address. This will update your info on our end and you will keep your Que position.

awesome, how much time does it take to get whitelisted? It's been 2 weeks, no news

New miners are whitelisted normally within the 1st 7 days of every month.
Reply
Hi

thank you for the awesome setup but i am a newbie to this and planning to setup one rig 

I have a few questions and it will be great if you can help me to clear my doughts 

# is it necessary to use OpenWRT Giga Router or can i use my home router TP-LINK TL-MR3220 3G/4G Wireless N Router?

# is there any minimum internet speed requirement?

# how much monthly internet data (GB/month) is required? 

# instead of raspberry pi is it possible to setup nods on multiple windows based thin client? 

please advise

thanks
Reply
(11-13-2018, 11:41 AM)same1116 Wrote: Hi

thank you for the awesome setup but i am a newbie to this and planning to setup one rig 

I have a few questions and it will be great if you can help me to clear my doughts 

# is it necessary to use OpenWRT Giga Router or can i use my home router TP-LINK TL-MR3220 3G/4G Wireless N Router?

# is there any minimum internet speed requirement?

# how much monthly internet data (GB/month) is required? 

# instead of raspberry pi is it possible to setup nods on multiple windows based thin client? 

please advise

thanks

No need to ask twice, I have replied in the thread you created

https://skywug.net/forum/Thread-Necessar...iga-Router
Reply
Hi the following is happening WTF am I doing wrong? Yes I am very very green at this

SSH is enabled and the default password for the 'pi' user has not been changed.
This is a security risk - please login as the 'pi' user and type 'passwd' to set a new password.


Wi-Fi is disabled because the country is not set.
Use raspi-config to set the country before use.

root@raspberrypi:~# cd ~
root@raspberrypi:~# mkdir -p $HOME/go/{bin,pkg,src}
root@raspberrypi:~# ls
go go1.10.3.linux-armv6l.tar.gz
root@raspberrypi:~# mkdir -p $GOPATH/src/github.com/skycoin
root@raspberrypi:~# cd $GOPATH/src/github.com/skycoin
root@raspberrypi:~/go/src/github.com/skycoin# git clone https://github.com/skycoin/skywire.git
-bash: git: command not found
root@raspberrypi:~/go/src/github.com/skycoin#

I think those 3 folders bin pkg and src are not there perhaps? installed wrong???
Reply
Hi
I am in need of help.
Just bought myself all I thought i needed for a 4 node DIY miner. (4 Rasp Pi 3B+, cables, TP-Link TL-SG1005D Gigabit Switch).
Ive connected it all up and flashed the 32gb SD cards with the testnet ready setup put on another forum on here.

Plugged it all in thru my Virginmedia broadband Superb 3.

When i have the first node plugged in it seems to work ok but as soon as i have the second i cannot connect to any node thru terminal on my mac.

I am thinking this may be down to the switch not being the correct one? I have tried plugging 3 of the nodes straight into the router but it doesn't recognise the 2nd and 3rd?

Any ideas?
Reply
(11-26-2018, 05:41 AM)Jamgars Wrote: Hi
I am in need of help.
Just bought myself all I thought i needed for a 4 node DIY miner. (4 Rasp Pi 3B+, cables, TP-Link TL-SG1005D Gigabit Switch).
Ive connected it all up and flashed the 32gb SD cards with the testnet ready setup put on another forum on here.

Plugged it all in thru my Virginmedia broadband Superb 3.

When i have the first node plugged in it seems to work ok but as soon as i have the second i cannot connect to any node thru terminal on my mac.

I am thinking this may be down to the switch not being the correct one? I have tried plugging 3 of the nodes straight into the router but it doesn't recognise the 2nd and 3rd?

Any ideas?

IP range of the virgin media router, and have you assigned static IPs to the PIs?
Reply
(11-26-2018, 05:00 PM)skyguy Wrote:
(11-26-2018, 05:41 AM)Jamgars Wrote: Hi
I am in need of help.
Just bought myself all I thought i needed for a 4 node DIY miner. (4 Rasp Pi 3B+, cables, TP-Link TL-SG1005D Gigabit Switch).
Ive connected it all up and flashed the 32gb SD cards with the testnet ready setup put on another forum on here.

Plugged it all in thru my Virginmedia broadband Superb 3.

When i have the first node plugged in it seems to work ok but as soon as i have the second i cannot connect to any node thru terminal on my mac.

I am thinking this may be down to the switch not being the correct one? I have tried plugging 3 of the nodes straight into the router but it doesn't recognise the 2nd and 3rd?

Any ideas?

IP range of the virgin media router, and have you assigned static IPs to the PIs?

Think ive figured it out.....not enough power to the pi's! Phew Thanks for help.
Reply
Hi.

///Rsb B+, setting one node, autostart on boot issue///

First i must admit that i have never seen such great support, reall great... and also i have issue.
I use preconfigured scripts, as seen on first page, including all editions to it.
I have only one node and it does not start on reboot automaticly... i must always  do it manualy with:


cd /home/pi/go/bin
nohup ./manager -web-dir /home/pi/go/src/github.com/skycoin/skywire/static/skywire-manager > /dev/null 2>&1 & echo $! > manager.pid &

cd /home/pi/go//bin
nohup ./node -connect-manager -manager-address 192.168.1.150:5998 -manager-web 192.168.1.150:8000 -discovery-address discovery.skycoin.net:5999-034b1cd4ebad163e457fb805b3ba43779958bba49f2c5e1e8b062482904bacdb68 -address :5000 -web-port :6001 > /dev/null 2>&1 &cd /


i tried to run autoscrips and i got :

pi@rpi01:/usr/local/sbin $ skywire.service
/usr/local/sbin/skywire.service: line 1: [Unit]: command not found
/usr/local/sbin/skywire.service: line 2: Service: command not found
/usr/local/sbin/skywire.service: line 5: [Service]: command not found
/usr/local/sbin/skywire.service: line 6: user: command not found
/usr/local/sbin/skywire.service: line 7: group]: command not found
/usr/local/sbin/skywire.service: line 11: [Install]: command not found
pi@rpi01:/usr/local/sbin $ ps aux | grep node

anny suggestions how to make  autostart "my precious" one node that will soon become 8 node brotherhood

tnx a lot!


Attached Files Thumbnail(s)
   
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)