Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Router in dyi skyminer, where exactly
#1
Hi,
I have DYI skyminer and my nodes are running all fine. But I have question, when i want connect to internet via nodes to use bandwith with skyminer, how can i achieve this? Now my swtich is connect to the ISP router and from switch goes cables to the orange pis. But where i have connect my second router? I just have now nodes running, but without bandwith.
Thanks very much, I am not pure technical type and I just dont know how to achieve bandwith.
Reply
#2
(06-05-2018, 02:17 PM)Liste Wrote: Hi,
I have DYI skyminer and my nodes are running all fine. But I have question, when i want connect to internet via nodes to use bandwith with skyminer, how can i achieve this? Now my swtich is connect to the ISP router and from switch goes cables to the orange pis. But where i have connect my second router? I just have now nodes running, but without bandwith.
Thanks very much, I am not pure technical type and I just dont know how to achieve bandwith.

To be sure I understand. You are running
Home Router > NodeRouter > switch > Nodes


Assuming I am understanding your connection properly. I assume your able to SSH into them?

If not, in order to achieve this you need to Port forward on your 2nd router. If your home router assigned the openwrt router an ip address of let's say 192.168.1.80 and you want to access your manager pi that is connected to your openwrt router. The manager pi will have an ip address either received via DHCP or broadcasted via static local configuration, but it will not be in the same subnet as your home router therefore it won't look like 192.168.1.x. Let's say your openwrt has assigned the manager pi an IP of 192.168.0.2. Now you need to setup a port forwarding rule to gain access to it. The rule will be specified inside the openwrt router. Depending on the router and the given options this can 'confusing' simply because of the amount of options you can choose from. Generally the port forwarding rule only needs a couple things specified: ip address to which the access should be forwarded to, external port (the port that is specified in the access to the openwrt router, we come back later to this point) and an internal port (the port on which the device that gets the forwarded access listens) as well as the used protocol (tcp or udp). So you just setup a rule for the manager pi:

Code:
ip address: 192.168.0.2
external port: 8000
internal port: 8000
used protocol: tcp+udp (if you can choose both separately just udp works)
name: Manager

This will enable you to access the managers webpage by querying the openwrt router at port 8000. In our example this would mean that from your laptop which is connected to your home router you type into your browser '192.168.1.80:8000' and you'll be able to view the managers webinterface. If you want to gain ssh access you can either use the provided terminal in the manager or you can setup the same port fowarding rule from above for port 22 (this is the default ssh port, depending on your router model and the number of pi's you have it can or cannot be possible to setup port forwarding rules for the same port even if the ip addresses differ. But this is not a problem and you shouldn't be concerned about it, since you can access all devices inside a subnet once you are connected to one of them via ssh).
[-] The following 1 user says Thank You to I Am You for this post:
  • Liste
Reply
#3
(06-05-2018, 05:29 PM)I Am You Wrote:
(06-05-2018, 02:17 PM)Liste Wrote: Hi,
I have DYI skyminer and my nodes are running all fine. But I have question, when i want connect to internet via nodes to use bandwith with skyminer, how can i achieve this? Now my swtich is connect to the ISP router and from switch goes cables to the orange pis. But where i have connect my second router? I just have now nodes running, but without bandwith.
Thanks very much, I am not pure technical type and I just dont know how to achieve bandwith.

To be sure I understand. You are running
Home Router > NodeRouter > switch > Nodes


Assuming I am understanding your connection properly. I assume your able to SSH into them?

If not, in order to achieve this you need to Port forward on your 2nd router. If your home router assigned the openwrt router an ip address of let's say 192.168.1.80 and you want to access your manager pi that is connected to your openwrt router. The manager pi will have an ip address either received via DHCP or broadcasted via static local configuration, but it will not be in the same subnet as your home router therefore it won't look like 192.168.1.x. Let's say your openwrt has assigned the manager pi an IP of 192.168.0.2. Now you need to setup a port forwarding rule to gain access to it. The rule will be specified inside the openwrt router. Depending on the router and the given options this can 'confusing' simply because of the amount of options you can choose from. Generally the port forwarding rule only needs a couple things specified: ip address to which the access should be forwarded to, external port (the port that is specified in the access to the openwrt router, we come back later to this point) and an internal port (the port on which the device that gets the forwarded access listens) as well as the used protocol (tcp or udp). So you just setup a rule for the manager pi:

Code:
ip address: 192.168.0.2
external port: 8000
internal port: 8000
used protocol: tcp+udp (if you can choose both separately just udp works)
name: Manager

This will enable you to access the managers webpage by querying the openwrt router at port 8000. In our example this would mean that from your laptop which is connected to your home router you type into your browser '192.168.1.80:8000' and you'll be able to view the managers webinterface. If you want to gain ssh access you can either use the provided terminal in the manager or you can setup the same port fowarding rule from above for port 22 (this is the default ssh port, depending on your router model and the number of pi's you have it can or cannot be possible to setup port forwarding rules for the same port even if the ip addresses differ. But this is not a problem and you shouldn't be concerned about it, since you can access all devices inside a subnet once you are connected to one of them via ssh).

Hi,
Thanks for answerSmile
Now I only have homerouter > switch > nodes
Yeah, I am able to ssh them from laptop and visit manager, where i Can see all my nodes

So I need one more router, and then in this router (in option) port forward Connection to one node (for example first), then i connect to node router and it will be good Smile)
Is that right?
Reply
#4
(06-05-2018, 06:58 PM)Liste Wrote:
(06-05-2018, 05:29 PM)I Am You Wrote:
(06-05-2018, 02:17 PM)Liste Wrote: Hi,
I have DYI skyminer and my nodes are running all fine. But I have question, when i want connect to internet via nodes to use bandwith with skyminer, how can i achieve this? Now my swtich is connect to the ISP router and from switch goes cables to the orange pis. But where i have connect my second router? I just have now nodes running, but without bandwith.
Thanks very much, I am not pure technical type and I just dont know how to achieve bandwith.

To be sure I understand. You are running
Home Router > NodeRouter > switch > Nodes


Assuming I am understanding your connection properly. I assume your able to SSH into them?

If not, in order to achieve this you need to Port forward on your 2nd router. If your home router assigned the openwrt router an ip address of let's say 192.168.1.80 and you want to access your manager pi that is connected to your openwrt router. The manager pi will have an ip address either received via DHCP or broadcasted via static local configuration, but it will not be in the same subnet as your home router therefore it won't look like 192.168.1.x. Let's say your openwrt has assigned the manager pi an IP of 192.168.0.2. Now you need to setup a port forwarding rule to gain access to it. The rule will be specified inside the openwrt router. Depending on the router and the given options this can 'confusing' simply because of the amount of options you can choose from. Generally the port forwarding rule only needs a couple things specified: ip address to which the access should be forwarded to, external port (the port that is specified in the access to the openwrt router, we come back later to this point) and an internal port (the port on which the device that gets the forwarded access listens) as well as the used protocol (tcp or udp). So you just setup a rule for the manager pi:

Code:
ip address: 192.168.0.2
external port: 8000
internal port: 8000
used protocol: tcp+udp (if you can choose both separately just udp works)
name: Manager

This will enable you to access the managers webpage by querying the openwrt router at port 8000. In our example this would mean that from your laptop which is connected to your home router you type into your browser '192.168.1.80:8000' and you'll be able to view the managers webinterface. If you want to gain ssh access you can either use the provided terminal in the manager or you can setup the same port fowarding rule from above for port 22 (this is the default ssh port, depending on your router model and the number of pi's you have it can or cannot be possible to setup port forwarding rules for the same port even if the ip addresses differ. But this is not a problem and you shouldn't be concerned about it, since you can access all devices inside a subnet once you are connected to one of them via ssh).

Hi,
Thanks for answerSmile
Now I only have homerouter > switch > nodes
Yeah, I am able to ssh them from laptop and visit manager, where i Can see all my nodes

So I need one more router, and then in this router (in option) port forward Connection to one node (for example first), then i connect to node router and it will be good Smile)
Is that right?

you dont need it. Its a Want more than a need. If possible, put a router into your network so you network connection goes

Home router ---WiFi--- OpenWRT router > Switch > Nodes
Reply
#5
(06-06-2018, 09:22 AM)I Am You Wrote:
(06-05-2018, 06:58 PM)Liste Wrote:
(06-05-2018, 05:29 PM)I Am You Wrote:
(06-05-2018, 02:17 PM)Liste Wrote: Hi,
I have DYI skyminer and my nodes are running all fine. But I have question, when i want connect to internet via nodes to use bandwith with skyminer, how can i achieve this? Now my swtich is connect to the ISP router and from switch goes cables to the orange pis. But where i have connect my second router? I just have now nodes running, but without bandwith.
Thanks very much, I am not pure technical type and I just dont know how to achieve bandwith.

To be sure I understand. You are running
Home Router > NodeRouter > switch > Nodes


Assuming I am understanding your connection properly. I assume your able to SSH into them?

If not, in order to achieve this you need to Port forward on your 2nd router. If your home router assigned the openwrt router an ip address of let's say 192.168.1.80 and you want to access your manager pi that is connected to your openwrt router. The manager pi will have an ip address either received via DHCP or broadcasted via static local configuration, but it will not be in the same subnet as your home router therefore it won't look like 192.168.1.x. Let's say your openwrt has assigned the manager pi an IP of 192.168.0.2. Now you need to setup a port forwarding rule to gain access to it. The rule will be specified inside the openwrt router. Depending on the router and the given options this can 'confusing' simply because of the amount of options you can choose from. Generally the port forwarding rule only needs a couple things specified: ip address to which the access should be forwarded to, external port (the port that is specified in the access to the openwrt router, we come back later to this point) and an internal port (the port on which the device that gets the forwarded access listens) as well as the used protocol (tcp or udp). So you just setup a rule for the manager pi:

Code:
ip address: 192.168.0.2
external port: 8000
internal port: 8000
used protocol: tcp+udp (if you can choose both separately just udp works)
name: Manager

This will enable you to access the managers webpage by querying the openwrt router at port 8000. In our example this would mean that from your laptop which is connected to your home router you type into your browser '192.168.1.80:8000' and you'll be able to view the managers webinterface. If you want to gain ssh access you can either use the provided terminal in the manager or you can setup the same port fowarding rule from above for port 22 (this is the default ssh port, depending on your router model and the number of pi's you have it can or cannot be possible to setup port forwarding rules for the same port even if the ip addresses differ. But this is not a problem and you shouldn't be concerned about it, since you can access all devices inside a subnet once you are connected to one of them via ssh).

Hi,
Thanks for answerSmile
Now I only have homerouter > switch > nodes
Yeah, I am able to ssh them from laptop and visit manager, where i Can see all my nodes

So I need one more router, and then in this router (in option) port forward Connection to one node (for example first), then i connect to node router and it will be good Smile)
Is that right?

you dont need it. Its a Want more than a need. If possible, put a router into your network so you network connection goes

Home router ---WiFi--- OpenWRT router > Switch > Nodes

And can I access nodes internet different than via second router? When I now have HomeRouter > Switch > Nodes, can I access it now? Or I just need second router, port forward connection and then for example from mobile/pc connect to wifi of node router (second router)
Reply
#6
Photo 
(06-06-2018, 11:08 AM)Liste Wrote:
(06-06-2018, 09:22 AM)I Am You Wrote:
(06-05-2018, 06:58 PM)Liste Wrote:
(06-05-2018, 05:29 PM)I Am You Wrote:
(06-05-2018, 02:17 PM)Liste Wrote: Hi,
I have DYI skyminer and my nodes are running all fine. But I have question, when i want connect to internet via nodes to use bandwith with skyminer, how can i achieve this? Now my swtich is connect to the ISP router and from switch goes cables to the orange pis. But where i have connect my second router? I just have now nodes running, but without bandwith.
Thanks very much, I am not pure technical type and I just dont know how to achieve bandwith.

To be sure I understand. You are running
Home Router > NodeRouter > switch > Nodes


Assuming I am understanding your connection properly. I assume your able to SSH into them?

If not, in order to achieve this you need to Port forward on your 2nd router. If your home router assigned the openwrt router an ip address of let's say 192.168.1.80 and you want to access your manager pi that is connected to your openwrt router. The manager pi will have an ip address either received via DHCP or broadcasted via static local configuration, but it will not be in the same subnet as your home router therefore it won't look like 192.168.1.x. Let's say your openwrt has assigned the manager pi an IP of 192.168.0.2. Now you need to setup a port forwarding rule to gain access to it. The rule will be specified inside the openwrt router. Depending on the router and the given options this can 'confusing' simply because of the amount of options you can choose from. Generally the port forwarding rule only needs a couple things specified: ip address to which the access should be forwarded to, external port (the port that is specified in the access to the openwrt router, we come back later to this point) and an internal port (the port on which the device that gets the forwarded access listens) as well as the used protocol (tcp or udp). So you just setup a rule for the manager pi:

Code:
ip address: 192.168.0.2
external port: 8000
internal port: 8000
used protocol: tcp+udp (if you can choose both separately just udp works)
name: Manager

This will enable you to access the managers webpage by querying the openwrt router at port 8000. In our example this would mean that from your laptop which is connected to your home router you type into your browser '192.168.1.80:8000' and you'll be able to view the managers webinterface. If you want to gain ssh access you can either use the provided terminal in the manager or you can setup the same port fowarding rule from above for port 22 (this is the default ssh port, depending on your router model and the number of pi's you have it can or cannot be possible to setup port forwarding rules for the same port even if the ip addresses differ. But this is not a problem and you shouldn't be concerned about it, since you can access all devices inside a subnet once you are connected to one of them via ssh).

Hi,
Thanks for answerSmile
Now I only have homerouter > switch > nodes
Yeah, I am able to ssh them from laptop and visit manager, where i Can see all my nodes

So I need one more router, and then in this router (in option) port forward Connection to one node (for example first), then i connect to node router and it will be good Smile)
Is that right?

you dont need it. Its a Want more than a need. If possible, put a router into your network so you network connection goes

Home router ---WiFi--- OpenWRT router > Switch > Nodes

And can I access nodes internet different than via second router? When I now have HomeRouter > Switch > Nodes, can I access it now? Or I just need second router, port forward connection and then for example from mobile/pc connect to wifi of node router (second router)

If you just have a single Router in your house, The usual home router setup. You use them like they are a normal PC, they will just work. No fancy portforwarding or anything.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)