Welcome, Guest
You have to register before you can post on our site.

Username
  

Password
  





Search Forums

(Advanced Search)

Forum Statistics
» Members: 1,499
» Latest member: Tigershreddingla
» Forum threads: 357
» Forum posts: 2,145

Full Statistics

Online Users
There are currently 61 online users.
» 0 Member(s) | 61 Guest(s)

Latest Threads
Zealot/Enemy (z-enemy) NV...
Forum: CryptoCurrency
Last Post: Devids
11 hours ago
» Replies: 1
» Views: 395
Pi Skyminer Setup brickwa...
Forum: Skywire
Last Post: nodejunky
07-17-2019, 04:19 PM
» Replies: 4
» Views: 255
DIY Skyminer on raspberry...
Forum: Skywire
Last Post: DDunn
07-12-2019, 03:30 PM
» Replies: 3
» Views: 376
Raspberry Pi 4: $35 compu...
Forum: Skywire
Last Post: I Am You
07-11-2019, 09:23 AM
» Replies: 1
» Views: 222
SRBMiner Cryptonight AMD ...
Forum: CryptoCurrency
Last Post: Monet
06-27-2019, 07:48 AM
» Replies: 0
» Views: 129
[Awesome Miner] - Powerfu...
Forum: CryptoCurrency
Last Post: Monet
06-24-2019, 08:50 PM
» Replies: 0
» Views: 165
Claymore's Dual Ethereum ...
Forum: CryptoCurrency
Last Post: Monet
06-24-2019, 07:04 AM
» Replies: 0
» Views: 183
[ANN] sgminer v5.6.0 - op...
Forum: CryptoCurrency
Last Post: Monet
06-22-2019, 07:42 PM
» Replies: 0
» Views: 132
Claymore’s Miner Manager ...
Forum: CryptoCurrency
Last Post: Monet
06-21-2019, 08:57 PM
» Replies: 0
» Views: 232
[JCE]Fast & stable CN/v8/...
Forum: CryptoCurrency
Last Post: Monet
06-21-2019, 07:40 AM
» Replies: 0
» Views: 119

 
  Updating or editing whitelist information
Posted by: radarlarry1 - 04-21-2019, 11:51 PM - Forum: Skywire - Replies (1)

Hello all!  I submitted my whitelist application 4 days ago.  I realize now that I did not enter proper architecture.  I think I just said 7 Orange Pi Primes and I don't think I had a wallet at that time.  I do now though.  Is that part of the whitelist application?  I can't remember.  Anyway, I'd like to be able to edit the info in the application to be more precise.  Even location, I only put Las Vegas, NV... not my address.  Am I correct in thinking that if my nodes are successfully whitelisted, it could not happen prior to 1 June. 2019?
Thanks,
Larry B.

Print this item

  Orange Pi Prime miner issues
Posted by: Radarlarrry - 04-17-2019, 09:05 PM - Forum: Skywire - No Replies

When I checked the monitor this morning, all seven nodes were up.  (One bad OPi)  However, in the STARTED column #7 said 10 hours ago, the rest said 38 minutes ago.  Does this indicate 1 thru 6 rebooted 38 minutes prior?  If so, why only 1-6 and not 7?  Is there an error log somewhere so I can see what happened?  Can I tell how long they were offline?
Now it's done it again, 2 hours ago... all except #7.

P.S. I don't have static IPs set for the Pis. Could this be happening when the addresses change? I would set them, but not exactly sure how to do it. The only info I could find on it is for RPi. I also did not do the port changes, as it seems to work fine on the ports as configured. But, what do I know?

Thanks,
Larry B.
[Image: Skyminer-2.jpg]

[Image: Skyminer3.jpg]

Print this item

  Orange : Pi Zero plus or Pi prime?
Posted by: mrtom31 - 04-13-2019, 05:10 PM - Forum: Skywire - No Replies

Hello fellow skycoinnoisseiur,

I am fairly new to this. I want to know before buying anything. Has anyone tried with Orange Pi Zero plus by following the guide :https://skywug.net/forum/Thread-Orange-Pi-Setup-Guide
and just replacing armbian for prime with zero plus ?

Is it safer to buy orang pi prime instead? (knowing that for 8 node it will be way mor expensive)

Thank you for reply,
mrtom

Print this item

  Practical Instructions
Posted by: FreedomDomains - 04-08-2019, 07:39 PM - Forum: Wireless Antennas - Replies (1)

Does anyone have practical instructions, tutorials, building plans, etc .. that could help new people get their antennas up and running?  I am looking for advice on hardware, software, or anything else as long as it is something you have tried and it worked for you.




Directions for installing the TP-Link AC600 USB wifi adapter on Orange Pi Prime running Armbian OS:  

 These directions include compiling a driver for the USB, and it is very important to make sure you have the EXACT linux-headers
 to match the architecture of your board and OS.  If the correct headers are not available anywhere, I would suggest buying a new
 micro sd card, and installing a version of Armbian that does have the correct headers available.  The instructions start there, but
 if you already have Armbian running and can verify that you will be able to install the correct headers you can skip to step 4.

 It is assumed you have the software tools to format the micro sd, to burn the Armbian image onto the sd, ssh to access the board,
 and 7-zip for windows.  I used a windows laptop to download and burn the image and access the ssh into the Orange Pi, but the directions
 would be similar for other OS's.

1.  Go to:

 https://www.armbian.com/orange-pi-prime

 Scroll down to Armbian Stretch section and click on direct download.  A pop up box will ask if you want to download.
 Check and make sure the name of the file ends in "Debian_stretch_next_4.19.20.7z" The 4.19.20 part is important because the
 version of Armbian that you download must be one that has linux-headers available for download for the EXACT same version.

 Click "ok" in the dialog box, and the file will be saved to your downloads folder (this is a large file, may take a few minutes)

 If you are seeing a version more recent than 4.19.20, cancel the download and go to:

 https://dl.armbian.com/orangepiprime/archive

 locate the link: Armbian_5.75_Orangepiprime_Debian_stretch_next_4.19.20.7z, double click on it and save it to your downloads folder

2.  Go into download folder and locate the file. RIGHT click on it and a menu will come up.
    Select 7-zip > extract to Armbian_5.75_Orangepiprime_Debian_stretch_next_4.19.20
    A folder will be created with that LONG name.  Click on the folder and locate a file named       "Armbian_5.75_Orangepiprime_Debian_stretch_next_4.19.20.img"
  You won't do anything with the file quite yet.  You just want to make sure it is there and you can find it.

3. Open the balenaEtcher software (it should be on your desktop with the "show icon")  Click "select image" Navigate to your downloads
  folder, find "Armbian_5.75_Orangepiprime_Debian_stretch_next_4.19.20.img", select it and click "Open"  Make sure that the second option
  in the balenaEtcher screen shows your micro sd card. If everything looks right, go ahead and click "Flash!"  Insert your mico sd into your   Orange Pi.

4. SSH into your Orange Pi Prime as root. The default root password for Armbian is "1234".  You will need to change that to a password of your choice.

  check running processes to see if Network Manager is on the list:

  root@orangepiprime:~# ps -aux
 
  Network Manager interferes with the proper functioning of the wifi driver you are about to install, so it needs to be disabled.
  First you need to add your "eth0" interface to "/etc/network/interfaces":

  root@orangepiprime:~# cd /etc/network
  root@orangepiprime:/etc/network# cp interfaces interfaces.orig
  root@orangepiprime:/etc/network# nano interfaces

  Inside the file you will see:

  auto lo
  iface lo inet loopback

  That should stay there. If you have specified a static IP for the Orange Pi in your
  router, add this stanza, changing the example IP addresses below to the correct ones:

   auto eth0
   iface eth0 inet static
       address 192.168.1.100 ## [static IP of orange pi]
       netmask 255.255.255.0 ## [this will probably stay the same]
       gateway 192.168.1.1 ## [IP address of your router]
       dns-nameservers 75.75.75.75  ## [the dns that your router uses]

  If your Orange Pi does not have static IP (it is assigned by router dhcp), add this stanza

   auto eth0
   allow-hotplug eth0
   iface eth0 inet dhcp

  Save the file.

  Specify your router DNS server(s) in resolv.conf:
  root@orangepiprime:/etc/network# cd ..
  root@orangepiprime:/etc# cp resolv.conf resolv.conf.orig
  root@orangepiprime:/etc# nano resolv.conf

  Inside that file write:

  search lan
  nameserver 75.75.75.75   ## [the dns that your router uses]

  Save the file

  Now you can disable Network Manager and reboot the board:

  root@orangepiprime:/etc# cd ~
  root@orangepiprime:~# systemctl disable network-manager
  root@orangepiprime:~# shutdown
  You should wait a minute or so, and then go ahead and power recycle the Orange Pi.
  SSH back into the Pi and check to make sure that Network Manager does NOT appear on the list of processes:

  root@orangepiprime:~# ps -aux

5.  You can now install the linux-headers. First check your exact architecture:

  root@orangepiprime:~# uname -a

  the part right after "Linux orangepiprime" should be "4.19.20-sunxi64"

  Update the repositories:

  root@orangepiprime:~# apt-get update  

  Search to make sure that the linux headers you will need are available:
  root@orangepiprime:~# apt-cache search linux-headers
  make sure you find in list:
  linux-headers-next-sunxi64 - Linux kernel headers for 4.19.20-sunxi64 on arm64

  If so, go ahead and install the headers:

  root@orangepiprime:~# apt-get install linux-headers-next-sunxi64

  Go look in /usr/src  now the correct headers should be there:
  root@orangepiprime:~# cd /usr/src
  root@orangepiprime:/usr/src# ls

6. Install some software needed to compile the driver:

   root@orangepiprime:/usr/src# cd ~
   root@orangepiprime:~# apt-get install mercurial bzr libgmp3-dev
   root@orangepiprime:~# apt-get install linux-kbuild-4.19

  The following should be up to date and not need to be installed, but if you want to be sure:
  root@orangepiprime:~# apt-get install binutils bison build-essential curl gcc git make

7. Get the mt7610u driver from github:

  root@orangepiprime:~# git clone https://github.com/FreedomDomains/mt7610u.git

8. Go into the mt7610u folder, copy the Makefile (in case you hose it up) and add a line to specify your symvers file:

  root@orangepiprime:~# cd mt7610u
  root@orangepiprime:~/mt7610u# cp Makefile Makefile.orig
  root@orangepiprime:~/mt7610u# nano Makefile

  Inside the file, scroll down to the "WFLAGS" section (around line 72) and add this line before the WFLAGS declarations:

  KBUILD_EXTRA_SYMBOLS :=/usr/src/linux-headers-4.19.20-sunxi64/Module.symvers  

  Save the file.

  (note that if you have a different architecture, the "linux-headers-4.19.20-sunxi64" part may be different. If in doubt,
   go into "/usr/source" to see the exact name of the directory)

9. Before compiling, the header scripts need to be compiled. Leave current directory and go into headers directory, and
  type "make scripts"

  root@orangepiprime:~/mt7610u# cd ~
  root@orangepiprime:~# cd /usr/src/linux-headers-4.19.20-sunxi64
  root@orangepiprime:/usr/src/linux-headers-4.19.20-sunxi64# make scripts

  If you are using the same architecture I used, you will get some errors including:

  scripts/kconfig/conf  --syncconfig Kconfig
  net/Kconfig:89: can't open file "net/wireguard/Kconfig"
  scripts/kconfig/Makefile:69: recipe for target 'syncconfig' failed

  You need to have Kconfig disregard the wireguard, which is not present. Go to "net" folder, copy Kconfig file (just in case):

  root@orangepiprime:/usr/src/linux-headers-4.19.20-sunxi64# cd net
  root@orangepiprime:/usr/src/linux-headers-4.19.20-sunxi64/net# cp Kconfig Kconfig.orig
  root@orangepiprime:/usr/src/linux-headers-4.19.20-sunxi64/net# nano Kconfig  

  on line 89 comment out:
  ## source "net/wireguard/Kconfig"

  Save file.

   Go back to the main headers folder, and "make scripts" again  (should work this time):

  root@orangepiprime:/usr/src/linux-headers-4.19.20-sunxi64/net# cd ..
  root@orangepiprime:/usr/src/linux-headers-4.19.20-sunxi64# make scripts

10.  Now it's time to go into the mt7610u driver folder and "make":

  root@orangepiprime:/usr/src/linux-headers-4.19.20-sunxi64# cd ~
  root@orangepiprime:~# cd mt7610u
  root@orangepiprime:~/mt7610u# make

  If you get errors about "redeclaration of enumerators, etc ..." that's because "mt7610u/include/rtmp.h"
  has declared variables which are also declared in headers, so those need to be commented out:

  root@orangepiprime:~/mt7610u# cd include
  root@orangepiprime:~/mt7610u/include# cp rtmp.h rtmp.h.orig
  root@orangepiprime:~/mt7610u/include# nano rtmp.h

 inside the file starting around line 5722  comment out this whole enum stanza:

/*  enum ieee80211_radiotap_type {

   IEEE80211_RADIOTAP_TSFT = 0,
   IEEE80211_RADIOTAP_FLAGS = 1,
   IEEE80211_RADIOTAP_RATE = 2,
   IEEE80211_RADIOTAP_CHANNEL = 3,
   IEEE80211_RADIOTAP_FHSS = 4,
   IEEE80211_RADIOTAP_DBM_ANTSIGNAL = 5,
   IEEE80211_RADIOTAP_DBM_ANTNOISE = 6,
   IEEE80211_RADIOTAP_LOCK_QUALITY = 7,
   IEEE80211_RADIOTAP_TX_ATTENUATION = 8,
   IEEE80211_RADIOTAP_DB_TX_ATTENUATION = 9,
   IEEE80211_RADIOTAP_DBM_TX_POWER = 10,
   IEEE80211_RADIOTAP_ANTENNA = 11,
   IEEE80211_RADIOTAP_DB_ANTSIGNAL = 12,
   IEEE80211_RADIOTAP_DB_ANTNOISE = 13

}; */

  Save the file. Go back to "mt7610u" folder and try again (should work this time):

  root@orangepiprime:~/mt7610u/include# cd ..
  root@orangepiprime:~/mt7610u# make
 

11. Install the firmware:
.
  root@orangepiprime:~/mt7610u# make installfw    

 (this will copy the firmware into your "/lib/firmware" directory.  these are the .bin files)

12. Copy the kernel module into the proper directory:

  root@orangepiprime:~/mt7610u# cp mt7610u.ko /lib/modules/4.19.20-sunxi64/kernel/drivers/net/wireless/

13. Enable the module:

  root@orangepiprime:~/mt7610u# cd ~
  root@orangepiprime:~# depmod 4.19.20-sunxi64    
       
14. Time to reboot and go back in:

   root@orangepiprime:/etc/modprobe.d# cd ~
   root@orangepiprime:~# shutdown

   SSH back into board and enable mt7610u:

   root@orangepiprime:~# modprobe mt7610u  
   (IMPORTANT don't add the .ko)

  Check which modules are active:

  root@orangepiprime:~# lsmod

 should show mt7610u in list

15. Get the configuration file in the right place (/etc/Wireless/RT2870STA/RT2870STA.dat):
   Make directories:

   root@orangepiprime:~# cd /etc
   root@orangepiprime:/etc# mkdir Wireless
   root@orangepiprime:/etc# cd Wireless
   root@orangepiprime:/etc/Wireless# mkdir RT2870STA

  Go back to "mt7610u" folder and copy the .dat file into the path you just made:

   root@orangepiprime:/etc/Wireless# cd ~
   root@orangepiprime:~# cd mt7610u
   root@orangepiprime:~/mt7610u# cp RT2870STA.dat /etc/Wireless/RT2870STA/
 
16. Make the config file for wpa_supplicant:

   root@orangepiprime:~/mt7610u# cd ~
   root@orangepiprime:~# cd /etc/wpa_supplicant
   root@orangepiprime:/etc/wpa_supplicant# nano wpa_supplicant.conf

   inside the file write:

   country=US    ## If outside US, use your country two digit code
   ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
   update_config=1

   network={
       ssid="mywifi"    ## use your actual router SSID
       key_mgmt=NONE
mode=0
scan_ssid=1
   }

  Save the file.

17. Shutdown the router:

   root@orangepiprime:/etc/wpa_supplicant# shutdown
   Completely shut off power supply, let the router rest a minute or two, then connect power and SSH back in.

18. Start up wpa_supplicant:

   root@orangepiprime:~# wpa_supplicant -Dnl80211 -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf

  you should see the lines:
  wlan0: Trying to associate with 09:00:f0:78:6e:5c (SSID='MyWifi' freq=2462 MHz)
  wlan0: Associated with 09:00:f0:78:6e:5c
  wlan0: CTRL-EVENT-CONNECTED - Connection to 09:00:f0:78:6e:5c completed

The usb stick should light up green

19. Don't do or type anything on this screen (it will break the connection)
   Start a new putty session to connect (or if you use something like Tmux even better)

   From the new session, check the active interfaces:

   root@orangepiprime:~# ifconfig
   
   you should now see the interface "wlan0" besides the "eth0" and "lo"

   Check the active processes to make sure wpa_supplicant is running:

   root@orangepiprime:~# ps -aux

   If you have trouble getting wpa_supplicant running you can add the -dd flag to get debug information:

   wpa_supplicant -dd -Dnl80211 -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf

20. To make sure your Orange Pi Prime is connected to your router wifi, use "iw":

   root@orangepiprime:~# iw dev

   You should see something like:

      You should see something like:

  phy#0
       Interface wlan0
               ifindex 3
               wdev 0x1
               addr f7:de:42:8d:1e:6a
               ssid mywifi
               type managed
               txpower 12.00 dBm

   The "iw" commands can be used to scan and join other hotspots as well as a ton of other functionalities.  
   If you want to learn more, a good place to start is:  

      https://wireless.wiki.kernel.org/en/user...ntation/iw

Print this item

  Second node doesn't connect to master node
Posted by: Stosh15x - 04-08-2019, 12:33 AM - Forum: Skywire - Replies (7)

Hello Everyone,

I am having an issue where my second node will not connect to the master node. When I try to connect the second node there seems to be a conflict and the master node will start to disconnect and reconnect. 

I followed https://skywug.net/forum/Thread-Raspberr...TNET-READY and then realized that the commands to start the nodes were incorrect according to the GitHub so I then used https://github.com/skycoin/skywire as my guide.

I have no issues with the master node running by itself and connecting to it through the web. So I am not quite sure what is going on with the second node. I imagine I am missing something simple but I cannot seem to figure it out through either guides I followed.

Hardware: 
2x Raspberry Pi 3 B+

Network: 
Master Node - 192.168.86.11
Second Node - 192.168.86.12


Masternode Commands:

Code:
nohup $GOPATH/bin/skywire-manager -web-dir ${GOPATH}/src/github.com/skycoin/skywire/static/skywire-manager > /dev/null 2>&1 &sleep 3

nohup $GOPATH/bin/skywire-node -connect-manager -manager-address :5998 -manager-web :8000 -discovery-address discovery.skycoin.net:5999-034b1cd4ebad163e457fb805b3ba43779958bba49f2c5e1e8b062482904bacdb68 -address :5000 -web-port :6001 > /dev/null 2>&1 &cd /

Second Node Commands:

Code:
nohup $GOPATH/bin/skywire-node -connect-manager -manager-address 192.168.86.11:5998 -manager-web 192.168.86.11:8000 -discovery-address discovery.skycoin.net:5999-034b1cd4ebad163e457fb805b3ba43779958bba49f2c5e1e8b062482904bacdb68 -address :5000 -web-port :6001 > /dev/null 2>&1 &cd /

Print this item

Photo Looking for bandwidth donation
Posted by: magicstone1412 - 03-26-2019, 02:22 PM - Forum: Skywire - No Replies

I have opened my miner for community using. But I do not know what the reason is, sometimes my miner drop in connection. Therefore, I worry if the new comers come to my site and wanna try socks 5 features, they can not use it and have a bad impression about skywire. Could someone please open your miner and donate your bandwidth to my site by connecting to duckdns.org and send me your information. I am really appreciate your donation.

Your information will be apprear as the below location on http://www.skywirex.com

[Image: pu5UKwl.png]

Print this item

  DIY Skyminer Using Orange Pi 3 ?
Posted by: Zensublime - 03-01-2019, 08:34 PM - Forum: Questions and Answers - No Replies

Im new to building a Skyminer myself.
I came across a post explaining how to make your own Skyminer using the same orange pi Prime boards used in the official Skyminer.
My question is, Would I be at much of an advantage going with the newer orange pi 3 ? Is the software installs the same?
The specs are a bit better on the 3, and only around $6 more for each.
Id like my build to be a little more future proof if possible.
I haven't been able to find any information regarding this.
I appreciate your time in advance!

Print this item

  GOLANG 1.12
Posted by: dontezuma - 02-26-2019, 06:54 AM - Forum: Skywire - Replies (1)

I'm installing the software for the miner now and noticed that the guides call for installing GO 1.11.4.  They recently released 1.2.  Should we be switching?  Or not, as the miner sofwater was on 1.11?

Print this item

Video Skycoin 2019 Review
Posted by: skyguy - 02-08-2019, 04:24 AM - Forum: Videos - No Replies



Print this item

  Skywire DIY RasperryPI 3 Model B + Tutorial sd card flash on Windows Vsta
Posted by: Kai - 02-01-2019, 10:38 AM - Forum: Skywire - No Replies

Hi folk, I'm giving you simple guide of how to install Skywire image on Raspberry Pi 3 modelB+ on Windows Vista.

Since I had trouble finding reliable software to flash image on sd card threw Windows Vista while Win32 disk imager and Etcher works only on Windows 7 and above we have solution for those above 7.

Takes quit time for whole process so be patient.


1(*). Download
pre-configured Raspian-skywire image from
       - http://bit.ly/skywire-raspian-image
                  - 879MB - Test Net Ready
       - Go, Git and Skywire pre-installed.
       - Skywire auto start scripts (attached below for reference)
       - Easy setup for any number of nodes (8, 16, 44, 128...).

2. Download
https://github.com/pbatard/rufus/release...s-2.18.exe
               - 1MB
3. Extract img file from zip from (1*)

4. Open Rufus insert sd card with adapter if neccessary (I choosen 16gb Kingston class 10 - ~3usd)
  - wait in label sd card to be recgonized and than below in format options where checkbox 'create a bootable disk using' choose in dropdown 'DD image' && right to it click on disk icon and find/submit iso image)
thats all you have to do in Rufus

5. click start, than OK for confirmation that everything from Sd card will be erased. Sit back may take for aprox. half to an hour to complete full write. After that, you if needed, same again for other nodes.


[Image: 20190201-110546.jpg]


6. After that pleawe Follow this thread to continue https://skywug.net/forum/Thread-Raspberr...TNET-READY

Crypto bless you.s

Print this item