Skycoin Forum
Set up 4 manager nodes? - Printable Version

+- Skycoin Forum (https://skywug.net/forum)
+-- Forum: Sky School (https://skywug.net/forum/Forum-Sky-School)
+--- Forum: Questions and Answers (https://skywug.net/forum/Forum-Questions-and-Answers)
+--- Thread: Set up 4 manager nodes? (/Thread-Set-up-4-manager-nodes)



Set up 4 manager nodes? - PiEBaLL - 12-21-2018

hi all, have a problem, ive tried to set up 4 nodes , 1 manager and 3 nodes, i can make all 4 run no problem as managers with their own web interface but once i try to link them to the manager it goes tits up 

im doing 

[color=rgba(0, 0, 0, 0.84)]sudo -i
cd /etc/init.d
nano MyScript.sh
[/color]

[color=rgba(0, 0, 0, 0.84)]then for manager[/color]

[color=rgba(0, 0, 0, 0.84)][color=rgba(0, 0, 0, 0.84)]#!/bin/sh
export GOPATH=$HOME/go
cd $GOPATH/bin
./manager -web-dir /root/go/src/github.com/skycoin/skywire/static/skywire-manager > /dev/null 2>&1 &
echo "Skywire is now running in the background. You can now access the Skywire Manager via the web browser"
sleep 5
cd $GOPATH/bin
./node -connect-manager -manager-address :5998 -manager-web :8000 -discovery-address discovery.skycoin.net:5999-034b1cd4ebad163e457fb805b3ba43779958bba49f2c5e1e8b062482904bacdb68 -address :5000 -web-port :6001 &> /dev/null 2>&1 &
echo "Skywire monitor started."
echo "You can now open the monitor in your browser: http://#.#.#.#:8000"
sleep 10
[/color]
[/color]
[color=rgba(0, 0, 0, 0.84)][color=rgba(0, 0, 0, 0.84)] [/color][/color]
[color=rgba(0, 0, 0, 0.84)][color=rgba(0, 0, 0, 0.84)]for nodes [/color][/color]

[color=rgba(0, 0, 0, 0.84)][color=rgba(0, 0, 0, 0.84)][color=rgba(0, 0, 0, 0.84)]#!/bin/sh
export GOPATH=$HOME/go
cd $GOPATH/bin
./manager -web-dir /root/go/src/github.com/skycoin/skywire/static/skywire-manager > /dev/null 2>&1 &
echo "Skywire is now running in the background. You can now access the Skywire Manager via the web browser"
sleep 5
cd $GOPATH/bin
./node -connect-manager -manager-address 192.168.0.101:5998 -manager-web 192.168.0.101:8000 -discovery-address discovery.skycoin.net:5999-034b1cd4ebad163e457fb805b3ba43779958bba49f2c5e1e8b062482904bacdb68 -address :5000 -web-port :6001 &> /dev/null 2>&1 &
echo "Skywire monitor started."
echo "You can now open the monitor in your browser: http://#.#.#.#:8000"
sleep 10
[/color]
[/color]
[/color]

[color=rgba(0, 0, 0, 0.84)][color=rgba(0, 0, 0, 0.84)]i had the 4 pis set up using a ready made image before but wanted to do a proper build and restarted, even tho i flashed the sd cards could there be something from the previous build somewhere conflicting with this, i even reset my modem [/color][/color]

[color=rgba(0, 0, 0, 0.84)][color=rgba(0, 0, 0, 0.84)]thanks in advance Big Grin [/color][/color]

sorry about the format of the post copy and paste seemed to add alot of junk in forget the colour code


RE: Set up 4 manager nodes? - PiEBaLL - 12-21-2018

if you ever run into this problem clear your internet cashie , i spent three days trying and trying again looking threw every bit of code and everything on the internet and that was all that was wrong, don't know why but atleast im up and running


RE: Set up 4 manager nodes? - I Am You - 12-22-2018

not the right place for this question. you should ask it in skywire as I don't have the power to move threads. But it looks to me like your running the manager on all 4 nodes while trying to just use them as nodes